Welcome to RailsBump! 👋

RailsBump lets you check your Ruby gems for compatibility with all major Rails versions. This is useful if you're planning to upgrade a Rails app to the next major version. You can either check an individual gem or a "lockfile" generated by Bundler (Gemfile.lock) containing all the gems of your Ruby project.
Read more about how RailsBump works and the history of this project on GitHub and please open an issue if you encounter any problems.

This project is sponsored by FastRuby.io. They are a team of Ruby on Rails experts that specialize in Rails Upgrade Services.

Check a gem Check a lockfile

Latest checked gems

Gem Show earlier Rails versions Compatible with...
Rails 2.3 Rails 3.0 Rails 3.1 Rails 3.2 Rails 4.0 Rails 4.1 Rails 4.2 Rails 5.0 Rails 5.1 Rails 5.2 Rails 6.0 Rails 6.1 Rails 7.0
shipping_easy <= 0.7.0 0.0.1 0.0.1 all all <= 0.7.0 all all all all all all all
basic-stats all all all all all all all all all all all all all
amazon-mws all all all all all all all all all all all all all
initials all all all all all all all all all all all all all
eos-icons-font none none all all some some some some some some some some some
edgecast all all all all all all all all all all all all all
config-parser all all all all all all all all all all all all all
outdatedbrowser_rails none none none none none none 1.1.3 none 1.1.4 1.1.4 1.1.5 1.1.5 none
jsonapi_errorable >= 0.6.2 >= 0.6.2 >= 0.6.2 >= 0.6.2 >= 0.6.2 all all all all all >= 0.6.2 >= 0.6.2 >= 0.6.2
jsonapi_compliable >= 0.5.1 >= 0.5.1 >= 0.5.1 >= 0.5.1 >= 0.5.1 all all all all all >= 0.5.1 >= 0.5.1 >= 0.5.1
wechat-rails none none none none none none none none none none none none none
mina-ng-puma none none all all all all all all all all all all all
dingtalk all all all all all all all all all all all all all
uirusu all all all all all <= 1.0.2 all all all all all all some
checkin all all all all all all all all all all all all all
clogger <= 1.3.0 <= 1.3.0 all all all all all some some some some some some
before_actions 1.0.0, 1.0.2, 2.0.3 1.0.0, 1.0.2, 2.0.3 all all all all all 1.0.0, 1.0.2, 2.0.3 1.0.0, 1.0.2, 2.0.3 1.0.0, 1.0.2, 2.0.3 1.0.0, 1.0.2, 2.0.3 1.0.0, 1.0.2, 2.0.3 1.0.0, 1.0.2, 2.0.3
shrine-transloadit all >= 0.4.2 >= 0.4.2 >= 0.4.2 all all all all all all all all all
aws-sdk-gamelift >= 1.40.0 >= 1.40.0 all all all all all all all all all all all
weaver all <= 0.6.4 <= 0.6.4 <= 0.6.4 <= 0.6.4 <= 0.6.4 <= 0.6.4 all all all all all all

Support

If you find RailsBump useful and would like to support the ongoing development, buy me a coffee or become a sponsor!